Die 22 Agent-Readiness-Checks
Der Scanner führt 22 Checks in fünf Kategorien aus. Jeder hat ein Bestehenskriterium, eine Nachweiskette und — bei Fehlschlag — einen Prompt, den Sie einem Coding-Agent übergeben können.
Auffindbarkeit
Kann ein Agent herausfinden, was Ihre Website ist und welche URLs zählen — ohne Ihr HTML nach Hinweisen zu durchsuchen?
robots.txt
Liefert HTTP 200 mit Klartext, der mindestens eine User-agent-Direktive enthält.
robots.txt Regeln für KI-Crawler
Sitemap
Unter /sitemap.xml wird eine gültige XML-Sitemap ausgeliefert, oder sie wird in robots.txt mit einer Sitemap:-Direktive deklariert.
Sitemap für KI-Agents
Link-Header
Die Antwort der Startseite enthält Link-Header mit mindestens einer für Agents nützlichen Relation.
HTTP Link-Header Agent-Discovery RFC 8288
DNS für KI-Discovery
Unter dem _agents-Namespace existieren ServiceMode-SVCB/HTTPS-Records oder ein TXT-Index, idealerweise DNSSEC-signiert.
DNS-AID Agent-Discovery SVCB
Inhalte
Wenn ein Agent Markdown anfordert: Liefern Sie dann sauberes Markdown zurück statt einer Wand aus Markup, die er erst parsen muss?
Bot-Zugriffskontrolle
Welche Richtlinie haben Sie für KI-Crawler festgelegt — und können Sie nachweisen, welche Anfragen von Ihnen stammen?
KI-Bot-Regeln
robots.txt nennt bekannte KI-Crawler oder enthält eine Wildcard-Gruppe, die sie abdeckt.
robots.txt KI-Bot User-agent-Regeln GPTBot ClaudeBot
Content Signals
robots.txt deklariert Content-Signal-Präferenzen für ai-train, search und ai-input.
Content Signals robots.txt ai-train search ai-input
Web Bot Auth
Unter /.well-known/http-message-signatures-directory wird ein JWKS veröffentlicht.
Web Bot Auth JWKS HTTP Message Signatures
API, Auth, MCP & Skill-Erkennung
Wenn Sie eine API, einen MCP-Server oder einen Agent betreiben: Ist er an der well-known-Position auffindbar, die ein Agent vermuten würde?
API Catalog
/.well-known/api-catalog liefert application/linkset+json mit mindestens einem Eintrag.
API Catalog RFC 9727 Linkset well-known
OAuth-Discovery
/.well-known/oauth-authorization-server oder /.well-known/openid-configuration stellt nutzbare Metadaten bereit.
OAuth OIDC Discovery Metadaten well-known
OAuth Protected Resource
/.well-known/oauth-protected-resource deklariert resource und authorization_servers.
OAuth Protected Resource Metadata RFC 9728
Auth.md
/auth.md existiert und enthält eine Markdown-H1, die auth.md erwähnt.
auth.md Agent-Registrierung Metadaten
MCP Server Card
/.well-known/mcp/server-card.json beschreibt den Server über serverInfo.name.
MCP Server Card well-known Discovery
A2A Agent Cardoptional
/.well-known/agent-card.json deklariert name, version und unterstützte Schnittstellen.
A2A Agent Card Agent-zu-Agent-Discovery
Agent Skills
/.well-known/agent-skills/index.json listet mindestens einen Skill auf.
Agent Skills Discovery Index SKILL.md
WebMCP
Seitencode registriert browserseitige Tools über navigator.modelContext.
WebMCP navigator.modelContext Browser-Tools
ARD-Manifest
/.well-known/ai-catalog.json deklariert specVersion, host und mindestens einen Eintrag.
ARD Agentic Resource Discovery ai-catalog
Commerce
Wird nur bewertet, wenn die Website wie ein Shop aussieht: Kann ein Agent bezahlen, bestellen und abrechnen, ohne dass ein Mensch ein Formular ausfüllt?
x402
Kostenpflichtige Routen antworten mit HTTP 402 und x402-Anforderungen, oder es wird ein Discovery-Dokument veröffentlicht.
x402 Agent-Zahlungen HTTP 402
MPP
Ein OpenAPI-Dokument kennzeichnet kostenpflichtige Operationen mit x-payment-info.
MPP Machine Payment Protocol OpenAPI x-payment-info
UCP
/.well-known/ucp deklariert protocol_version und mindestens einen Service.
UCP Universal Commerce Protocol well-known
ACP
/.well-known/acp.json deklariert protocol.name, api_base_url, transports und capabilities.services.
ACP Agent Commerce Protocol Discovery
AP2optional
Die A2A Agent Card weist eine AP2-Erweiterung mit Rolleninformationen aus.
AP2 Agent Payments Protocol A2A-Erweiterung
Ready to see where you stand?
Run the scanner against your own domain and get the fix list.