22 एजेंट-तैयारी जाँचें
स्कैनर पाँच श्रेणियों में 22 जाँचें चलाता है। हर जाँच का एक पास मानदंड, एक साक्ष्य-शृंखला, और विफल होने पर एक प्रॉम्प्ट होता है जिसे आप किसी कोडिंग एजेंट को सौंप सकते हैं।
खोजयोग्यता
क्या कोई एजेंट आपकी HTML में सुराग ढूँढ़े बिना यह जान सकता है कि आपकी साइट क्या है और कौन-से URL मायने रखते हैं?
robots.txt
HTTP 200 के साथ plain text लौटाता है, जिसमें कम से कम एक User-agent निर्देश हो।
robots.txt AI क्रॉलर नियम
Sitemap
/sitemap.xml पर मान्य XML sitemap उपलब्ध है, या robots.txt में Sitemap: निर्देश से घोषित है।
AI एजेंट के लिए sitemap
Link हेडर
होमपेज का रिस्पॉन्स Link हेडर के साथ आता है, जिनमें कम से कम एक एजेंट-उपयोगी relation हो।
HTTP Link हेडर एजेंट खोज RFC 8288
AI खोज के लिए DNS (DNS-AID)
_agents नेमस्पेस के अंतर्गत ServiceMode SVCB/HTTPS रिकॉर्ड या TXT इंडेक्स मौजूद है, आदर्श रूप में DNSSEC से साइन किया गया।
DNS-AID एजेंट खोज SVCB
कंटेंट
जब एजेंट Markdown माँगता है, तो क्या आप पार्स करने के लिए ढेर सारा मार्कअप थमाने के बजाय साफ़ Markdown लौटाते हैं?
बॉट पहुँच नियंत्रण
आपने AI क्रॉलरों के लिए क्या नीति बताई है, और क्या आप साबित कर सकते हैं कि कौन-से अनुरोध आपके हैं?
AI बॉट नियम
robots.txt में ज्ञात AI क्रॉलरों के नाम हैं, या ऐसा वाइल्डकार्ड ग्रुप है जो उन्हें कवर करता है।
robots.txt AI बॉट User-agent नियम GPTBot ClaudeBot
Content Signals
robots.txt में ai-train, search और ai-input को कवर करने वाली Content-Signal प्राथमिकताएँ घोषित हैं।
Content Signals robots.txt ai-train search ai-input
Web Bot Auth
/.well-known/http-message-signatures-directory पर JWKS प्रकाशित है।
Web Bot Auth JWKS HTTP मैसेज सिग्नेचर
API, प्रमाणीकरण, MCP और स्किल खोज
अगर आप API, MCP सर्वर या एजेंट उपलब्ध कराते हैं, तो क्या वह उसी well-known स्थान पर मिलता है जहाँ एजेंट खोजेगा?
API Catalog
/.well-known/api-catalog, application/linkset+json लौटाता है, जिसमें कम से कम एक प्रविष्टि हो।
API Catalog RFC 9727 linkset well-known
OAuth खोज
/.well-known/oauth-authorization-server या /.well-known/openid-configuration उपयोगी मेटाडेटा उजागर करता है।
OAuth OIDC खोज मेटाडेटा well-known
OAuth Protected Resource
/.well-known/oauth-protected-resource, resource और authorization_servers घोषित करता है।
OAuth Protected Resource मेटाडेटा RFC 9728
Auth.md
/auth.md मौजूद है, और उसके Markdown H1 में auth.md का ज़िक्र है।
auth.md एजेंट रजिस्ट्रेशन मेटाडेटा
MCP Server Card
/.well-known/mcp/server-card.json, serverInfo.name के साथ सर्वर का वर्णन करता है।
MCP Server Card well-known खोज
A2A Agent Cardoptional
/.well-known/agent-card.json, name, version और समर्थित इंटरफ़ेस घोषित करता है।
A2A Agent Card एजेंट-से-एजेंट खोज
Agent Skills
/.well-known/agent-skills/index.json में कम से कम एक स्किल सूचीबद्ध है।
Agent Skills खोज इंडेक्स SKILL.md
WebMCP
पेज का कोड navigator.modelContext के ज़रिए ब्राउज़र-साइड टूल्स रजिस्टर करता है।
WebMCP navigator.modelContext ब्राउज़र टूल्स
ARD मैनिफ़ेस्ट
/.well-known/ai-catalog.json, specVersion, host और कम से कम एक प्रविष्टि घोषित करता है।
ARD Agentic Resource Discovery ai-catalog
कॉमर्स
स्कोर केवल तब मिलता है जब साइट स्टोर जैसी लगे: क्या कोई एजेंट बिना किसी इंसान के फ़ॉर्म भरे भुगतान, ऑर्डर और सेटलमेंट कर सकता है?
x402
भुगतान योग्य रूट HTTP 402 के साथ x402 की शर्तें लौटाते हैं, या खोज दस्तावेज़ प्रकाशित है।
x402 एजेंट भुगतान HTTP 402
MPP
OpenAPI दस्तावेज़ भुगतान योग्य ऑपरेशनों को x-payment-info से चिह्नित करता है।
MPP मशीन भुगतान प्रोटोकॉल OpenAPI x-payment-info
UCP
/.well-known/ucp, protocol_version और कम से कम एक सर्विस घोषित करता है।
UCP Universal Commerce Protocol well-known
ACP
/.well-known/acp.json, protocol.name, api_base_url, transports और capabilities.services घोषित करता है।
ACP एजेंट कॉमर्स प्रोटोकॉल खोज
AP2optional
A2A Agent Card, भूमिका की जानकारी के साथ AP2 एक्सटेंशन की घोषणा करता है।
AP2 एजेंट भुगतान प्रोटोकॉल A2A एक्सटेंशन
Ready to see where you stand?
Run the scanner against your own domain and get the fix list.